Page 1 of 6

Prepar3D V5: compatibility with existing products

Posted: Wed Apr 08, 2020 4:23 pm
by doodlebug
We are currently testing our products in LM Prepar3D V5.
Results so far:
  • Advanced series products: non-functional
  • WX bundled products: non-functional
  • All other products: testing ongoing
With products bundled with 3rd party addons (TacPack, WX, etc) a definitive answer, as to if and when a solution will be ready, is unfortunately out of our hands.
For the rest, we hope to have answers within the next 2 weeks. Until we have confirmed your aircraft is compatible, please assume it isn't.

Please note that we hope we won't have to charge for this update, but we might have to, depending on the work involved.

Re: Prepar3D V5: compatibility with existing products

Posted: Sun Apr 26, 2020 10:58 am
by skyhawk18
TrueGlass and RealLight needs to be disabled to avoid crashes in P3D v5.

Re: Prepar3D V5: compatibility with existing products

Posted: Sun Apr 26, 2020 11:57 am
by SnuffyTheMongoose
and the wx... and, in some cases, the products won't work no matter what you do. This is why they are not rated as compatible... yet.

Re: Prepar3D V5: compatibility with existing products

Posted: Tue May 05, 2020 12:31 pm
by albix
Almost one month is passed since your announcement that in "a couple of weeks" you would have released the P3dV5 update.
I have purchased the K.A. in 2015 and still have not been able to install it. It took a lifetime to be released and when finally the final version was published I found out that it was only working with Windows 10. I was still on Windows 7 so I decided to move to the 10 but in the meantime P3dV5 was released and again I couldn't install it because not compatible. I am anxiously waiting (for five years now!) to see what I have spent my money for.
Now the question: Do you have a date for the release of the P3dV5 version?
Thank you!

Re: Prepar3D V5: compatibility with existing products

Posted: Wed May 06, 2020 12:16 am
by SnuffyTheMongoose
v5 support for the KA is incoming for those who have purchased it. For all other products, we will, sadly, be charging for the updates. That said, it is our intention to add PBR for all of those products that don't have it.

We are looking at between 10 and 15 bucks...

Re: Prepar3D V5: compatibility with existing products

Posted: Wed May 06, 2020 10:31 am
by vvince
Very sad indeed.
Especially knowing that an update has already been charged for some product not long ago (the T38A).
And the T38C is a recent release too.
Being charged two times for updating one single product in about a year time is a bit too much to my taste honestly.

Re: Prepar3D V5: compatibility with existing products

Posted: Wed May 06, 2020 11:25 am
by SnuffyTheMongoose
The T-38A is not a new product... The T-38C is a special case because it's not longer for sale.

Not sure how you're being charged twice...

Re: Prepar3D V5: compatibility with existing products

Posted: Wed May 06, 2020 12:44 pm
by vvince
The T38A (advanced) has been updated recently in April 2019 if I recall correctly (T38A Redux, with PBR. Well actually looking more carefully it was some sort of a new release since the old T38A adv is still available). It was not a free update.
That's what I mean with being charged twice for updating one single product within a one year period.

That the T38C is no longer for sale does not change the fact that those who bought it one year ago when it came out will have to pay for the update if they want to use it in P3Dv5. So again being charged two times within about one year time.

Since those two planes already have PBR, the added value of the update seems to be v5 compatibility only, which could be expected to be free since the last release/paid update is quite recent. Well, at least that's how I see it... I of course have no idea how much developer time is involved in making the planes v5 compatible.

Re: Prepar3D V5: compatibility with existing products

Posted: Wed May 06, 2020 1:15 pm
by SnuffyTheMongoose
While I understand your point of view, It costs us time, effort and yes, money, to do the ports. Our products are not simply XML based and easily ported. In a perfect world, this would all take moments and be free... FREE!!!! But no. That's not how it works.

I am sorry but I have to feed my team and make sure that people get paid for the work that they do for us.

You are free to buy or not to buy. It's your money.

Re: Prepar3D V5: compatibility with existing products

Posted: Fri May 08, 2020 9:05 pm
by xxd09
Really enjoy all your planes with their Addons
A low slow bush flight in a snow storm in a Beaver with GTN 750 and WX Radar getting me home safe and sound is a delight somewhere in the Pacific North West
All running beautifully in P3Dv 4.5h2
P3Dv 5 is another jump so I am happy to wait till you have your v5 installers in place -it does seem to be another quantum leap
We are truly spoilt by the quality of our aircraft
Happy to pay if that is what it takes to keep you in business
Looking forward to the new installers
xxd09

Re: Prepar3D V5: compatibility with existing products

Posted: Sat May 09, 2020 1:11 pm
by Denisgerard
Hi, i hope military jet too , it's been a looooong tiiiime ;)

Re: Prepar3D V5: compatibility with existing products

Posted: Sat May 09, 2020 1:46 pm
by Sharpedge
If you need any beta testers for the KA350 in P3DV5 I will gladly lend my time and pc to the effort 8-)

Re: Prepar3D V5: compatibility with existing products

Posted: Sat May 09, 2020 3:04 pm
by SnuffyTheMongoose
Thanks. I think we have that one under control...

Re: Prepar3D V5: compatibility with existing products

Posted: Sat May 09, 2020 10:00 pm
by RicardoGroizard
SnuffyTheMongoose wrote:
Wed May 06, 2020 12:16 am
v5 support for the KA is incoming for those who have purchased it. For all other products, we will, sadly, be charging for the updates. That said, it is our intention to add PBR for all of those products that don't have it.

We are looking at between 10 and 15 bucks...
Wrong policy, Less people will fly your birds from now, less people will talk about your birds. I paid for MD530 PBR version as it was realesed, I have two of the otters, pc6, b7200, bell 407, kia350, and c310r p3d and xp version. You are loosing one proffitable customer now.

Re: Prepar3D V5: compatibility with existing products

Posted: Sun May 10, 2020 12:39 am
by SnuffyTheMongoose
KA purchasers will not be charged for the update. For all products that require work/effort/time/money to process and update, will, sadly, be charged.