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This software is an artistic representation
of the subject matter.

Any similarities to any commercial product, equipment, ve-
hicle, device or other, present within this artistic represen-
tation does not constitute or imply an endorsement (by, or
of) the manufacturer(s) and/or trademark holder(s) of that
which may be deemed similar.

This software, including any and all components and con-
tent, © 2018 Military Visualizations Inc. All Rights Reserved.

No replication, reduction, reverse engineering or unauthor-
ized addition to the software, either in whole or in part, is
permitted in any form without the express written permis-
sion of Military Visualizations Inc.

By installing this software, you are hereby agreeing to the
above terms and conditions. Any breach of the above EULA
will result in litigation, removal of license and/or forfeiture of
continued support.

Any inquiries regarding academic or other professional use

of this software should be directed via e-mail to info@milviz.
com.
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Welcomel

This User Guide has been prepared to help you
get started with your new Turbo 310R for X-Plane.

It contains useful information about your Turbo
310R’s equipment, operating procedures, and
performance. It also contains instructions for in-
stallation and updating. We recommend that you
take some time to read through this guide from
cover to cover, and to refer to it as needed.

Our interest in your simulation activity has not
ceased with your purchase of the MilViz Turbo
310R. Worldwide, the Military Visualizations staff
stands ready to assist and serve. For technical

support, please post a request on our Turbo 310R
X-Plane support forum. Our dedicated and tal-
ented staff is ready to help you.

For forum access please email oisin@milviz.com
with your proof of purchase and your preferred or
existing forum username.

Bringing the 310R to X-Plane

This isn't the first version of the 310R to wear the
MilViz label. The original version of the MilViz 310R
was released way back in 2010 in Microsoft Flight
Simulator X, well known not only for it's accurate
portrayal of the iconic twin but also for the care-
fully tuned and realistic flight model.

In the spring of 2018 we released the 310R Redux,
for FSX and Prepar3d. This version was a com-
plete overhaul of the original, with enhanced and
updated systems programming, an updated vir-
tual cockpit, new external textures, and a brand
new soundset. In other words, pretty much ev-
erything required in order to bring this aircraft up
to current standards.

In bringing the 310R into the X-Plane world, we've
retained the same excellent standards that we're
know for, while taking advantage of all of the
modern technology available to us in X-Plane 11.

We're happy to be here, and we're very happy that
you could join us. Thanks and enjoy the ridel
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Product Features

> Designed for X-Plane 11
» Optimized for X-Plane 11 engine and handling behavior
» Inclusion of PBR materials and textures
» Advanced FMOD sounds inside and out

> High Quality Textures & Modeling
» Physical Based Rendering (PBR) materials and textures for superb
real-time reflections and shine
» Exterior and interior rendered with exacting detail and precision
» High resolution, beautiful textures with realistic weathering effects
» Smoothly animated parts inside and out

> Realistic Simulation of the Turbo 310R
» Behavior designed to closely simulate the real world
» Authentic turbo performance and handling
» Realistic fuel load and tank capacities
» Realistic weight & balance
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» Advanced Autopilot System
» Autopilot mimics real world behavior, requiring hands-on operation
» Simulation of VOR station ‘Cone of Confusion” when approaching
VOR station, requiring monitoring and switching from NAV to HDG
to maintain proper course
» Servo behavior which lacks in speed and accuracy as per real world
examples

» GPS Configuration Options
» FPS friendly X-Plane GNS 530 & GNS 430 included by default
» Includes support for RealityXP’s GTN 750* & 650* integrated into
the 3D cockpit

» Custom Aircraft Panel
» In-game menu panel allows for display of ground elements,
switching liveries and changing the GPS displays
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System Requirements

Supported Platforms: X-Plane 11
The following requirements apply as a
minimum to successfully install, con-
figure and operate the MilViz Turbo Supported Operating Systems: All operating systems which are supported by the
310R for X-Plane. _X—Plladne 11 platform. At the time of publication, this
includes:

(Please that tr_le_se requirements rep- . 0S X: 0S X 1010 or newer

resent the minimum required; your - Windows: Windows 7, 8, or 10, 64-bit

choice of scenery, location, and sim- « Linux (While any distribution which successfully
ulator settings may place additional runs X-Plane 11 should be capable of operating this
demands on your simulation platform aircraft, distribution specific issues with X-Plane
that may ultimately affect your simu- 11 that may causes issues with this aircraft are not
lator experience.) supported.)

Processor (CPU): Intel Core i3, i5, or i7 CPU with 2 or more cores,
or AMD equivalent. (Recommended: Intel Core
i5 6600K at 3.5 ghz or faster.)

©0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000

Video Card (GPU): DirectX 11-capable video card from NVIDIA, AMD or In-
tel with at least 1 GB VRAM. (Recommended: DirectX
12-capable video card from NVIDIA, AMD or Intel with
at least 4 GB VRAM, GeForce GTX 1070 or better or
similar from AMD.)

©0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000

System Memory (RAM): 8 GB RAM (Recommended: 16-24 GB RAM or more.)
Hard Drive: 1.5 GB or greater free hard drive space.
Gaming Controller: Joystick, yoke, or other gaming controller (a means of

controlling the aircraft rudder, either with twist joy-
stick function or dedicated pedals, is additionally rec-
ommended).
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Beginning Installation

After purchase, you will have been given a link
or an option to download a compressed file. This
compressed file contains all of the folders and
files for the MilViz Turbo 310R for X-Plane.

Using a file compression utility of your choice, de-
compress this file to a location or folder of your
choosing.

(At time of purchase, you will also have been giv-
en a product key. This key will be entered in the
last step.)
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Identifying Files to Copy

Within this newly decompressed folder, you will
find a sub-folder marked with a version number
containing both files and folders.

You'll know that you have identified the correct
folder when it looks like the below image.

This folder is the aircraft folder that needs to be
placed within the X-Plane file structure.

Creating a Destination Folder

In the X-Plane 11 file structure, all aircraft are
placed within the ‘X-Plane 11\Aircraft’ folder, gen-
erally in developer specific folders. This structure
helps to organize your aircraft collection.

While it is largely up to the end user on how they
wish to organize their aircraft, we recommend
creating a sub-folder within the ‘X-Plane 11\Air-
craft’ folder titled ‘MilViz'.

.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.

MILVIZZ——




Turbo 310R User Guide

Installation Instructions (continued)

Page 5

Copying the Aircraft

You should now have a folder structure that re-
sembles the following:

‘X-Plane 1M\Aircraft\MilViz’

Copy the aircraft folder you identified in Step 2
into this newly created MilViz folder. Done cor-
rectly, it should closely resemble the following
image.

Verify Installation

Once the aircraft folder is installed correctly,
launch X-Plane 11.

On the left side of the Flight Configuration Ul
screen, you should be able to find your new Turbo
310R.

You may now select it and start a flight (making
any other desired adjustments to starting loca-
tion & weather, of course).

Product Key Registration

At time of purchase, you should also have been
given a product key. This product key is used to
register your aircraft, and is tied to your individual
purchase.

On the first launch of the aircraft, a window will
automatically show, asking for the product key.
Enter the key you received and press the ‘Regis-
ter’ button to continue.

You aircraft is now ready for use!l
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Product Support

The MilViz Turbo 310R may be un-installed very
simply by deleting the aircraft folder that you
manually copied into the X-Plane 11 file structure.

Note: Prior to uninstalling the aircraft, please be
sure to back up any customized files or custom
liveries you have installed if you wish to keep
them.

® 0000000000000 0000000000000000000000000 e oo TRNEEERTETIE

In the event that you are notified of an update to
the MilViz Turbo 310R, it is highly recommended
that you completely uninstall the previous ver-
sion before you install the newly updated version.
This will ensure that the correct versions of any
changed files are present.

® 0000000000000 0000000000000000000000000 e oo TRNEEERTETIE

We are deeply committed to the satisfaction of
our customers. If you encounter any issues with
your product or require assistance, or just have a
general question, we encourage you to visit our
forums at http:/milviz.com/forum/.

Support forums for our individual products are
restricted to owners of that product. To regis-
ter for a specific support forum, please contact
oisin@milviz.com for registration information and
details. Please note that proof of purchase will be
required.

—MILVIZ
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Number of Engines
Engine Model Number:

Engine Type:

Horsepower:

Propellers:

2
TSIO-520-BB

Turbocharged, fuel injected, di-

rect drive, air-cooled, horizontally

opposed, six cylinder, 520 cubic-
inch displacement.

285 rated horsepower at 2700
RPM and 32.0 inches Hg. mani-
fold pressure to the critical alti-
tude of 16,000 feet.

2, 3-blade, 6’ 6" diameter, con-
stant speed, full feathering, non-
reversible hydraulically actuated.

Recommended Settings & Speeds

Maximum Takeoff Weight:
Maximum Landing Weight:
Maximum Zero Fuel Weight:
Standard Empty Weight:
Maximum Useful Load:

Main Fuel Tanks - Usable
Auxiliary Fuel Tanks - Usable
Total Wing Area:

Wing Loading:

Power Loading:

5500 Ibs

5400 Ibs

5015 Ibs

3467 Ibs

2068 Ibs

100 U.S. Gallons (total)
63 U.S. Gallons (total)
179 square feet

30.73 Ibs per square foot

9.65 Ibs per horsepower

Normal Takeoff:

Max Performance Takeoff:

Best Angle-of-Climb Speed (S.L.):

Best Rate-of-Climb Speed (S.L.):
Cruise Climb:

Maximum Climb:

Cruise:

Minimum Multi-Engine Approach
Speed:

2700 RPM, Full Throttle, Flaps 0°
2700 RPM, Full Throttle, Flaps 15°

2350 RPM, 29 In. Hg.

2700 RPM, Full Throttle below
16,000 feet, Max allowable M.P.
above 16,000 feet.

2100 to 2350 RPM and 15.0 to 29.0

In. Hg. or 2200 to 2300 RPM and
15.0 to 30.0 In. Hg.

Raise nosewheel at 80 KIAS, Lift-off at 92 KIAS (5500 lbs Max Weight)
Raise nosewheel at 70 KIAS, Lift-off at 82 KIAS (5500 lbs Max Weight)

81KIAS (at 5500 Ibs Max Weight)

105 KIAS (at 5500 Ibs Max Weight)

115 to 140 KIAS
105 KIAS

93 KIAS (at 5400 Ibs Max Weight)

MLV Z
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Aircraft Limitations

Operational Limitations

Maneuvering Speed VA (knots) 148 KIAS Do not make abrupt or sudden control movements above this speed.

Maximum Flap Extended Speed VFE (Knots) 15° 158 KIAS Do not exceed this speed at this flap setting.

Maximum Flap Extended Speed VFE (Knots) 35° 139 KIAS Do not exceed this speed at this flap setting.

Maximum Gear Operating Speed VLO (Knots) 138 KIAS Do not operate the landing gear above this speed.

Maximum Gear Extended Speed VLE (Knots) 138 KIAS Do not extend the landing gear above this speed.

Air Minimum Control Speed VMCA (Knots) 80 KIAS This is the minimum speed at which the aircraft is controllable with one engine
inoperative and a 5° bank towards the operative engine

One Engine Inoperative Best Rate-of-Climb Speed Vy 106 KIAS The speed delivering the greatest gain in altitude in the shortest time with one

(Knots) engine inoperative at sea level, standard day conditions and level flight

Never Exceed Speed VNE (Knots) 223 KIAS Do not exceed this speed in any type of operation

Maximum Cruising Speed VNO (Knots) 181 KIAS Do not exceed this speed except in smooth air and with caution

Engine Limitations

Altitude (Feet) Allowable Engine Brake
Manifold RPM Horse-
Pressure power
(In. Hg.)
S.L.to 16,000 feet 32.0 2700 285
18,000 30.7 2700 268
20,000 29.0 2700 246
22,000 26.4 2700 222
24,000 24.3 2700 198
26,000 22.2 2700 176
28,000 20.2 2700 155
30,000 18.5 2700 136
32,000 17.0 2700 17
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The MilViz Turbo 310R includes a custom aircraft
menu panel which is accessible once the aircraft
is loaded. From this menu, it's possible to perform
the following actions:

> Remove / Attach external features
» Change Aircraft Liveries
> Switch between GPS options

The menu panel may be opened (or closed) by uti-
lizing the X-Plane Menu Bar located at the top of
the screen, and choosing “Plugins > MilViz T310R
> Show/Hide Options”.

Clicking on the images of the chocks or the ‘Re-
move Before Flight' flag allows you to hide or
show those respective features on the aircraft.

The next section allows you to switch aircraft liv-
eries on the fly by clicking the arrows to the left or
right of the aircraft image.

The GPS options allow you to switch between the
stock X-Plane GNS 530/430 and the RealityXP
GTN 750/650 variants (not included).

To switch, click the image shown for either Nav
1 or Nav 2. The changes will immediately be re-
flected in the aircraft.

IMPORTANT: When transitioning between the
Reality XP GTN 750 and the stock X-Plane GNS
530, be sure to turn the GTN 750 OFF in the pl-
ugins menu. This is found at ‘Plugins>Reality XP
GTN> GTNT..

MILVIZ " 7370R

MILITARY VISUALIZATIONS

VA

Ground Equipment

Livery changer

<

Select

GPS Variant X-Plane 11 X-Plane 11
Default GNS-530 Default GNS-430
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For this portion of the T310R user guide, we've
elected to present a step-by-step walkthrough of
how to take the Turbo 310R from a cold and dark
state all the way up to being ready for taxi and
takeoff.

This is provided in lieu of a pseudo-realistic se-
ries of procedural checklists which, although of-
ten containing a wealth of information of interest
to those wanting to mimic the full scope of pilot
activities, cover many areas not relevant to simu-
lator use and don't always do a lot to help a newer
pilot find their bearings.

The systems and engine management in the Tur-
bo 310R is not exceedingly complex and do not
need in-depth coverage in order to successfully
operate the aircraft, given that there is no cus-
tom failure or wear-n-tear simulation included.

Instrumentation included in the T310R panel is
fairly standard and the interpretation of such
should be familiar to simulation pilots.

Failures that are a default part of the X-Plane plat-
form are not within our scope of coverage. Such
failure modes are generic to all aircraft within the

simulator and do not need to be addressed by our
guide. The use of such modes is not discouraged
nor recommended; it is purely left to user choice.

Aside from the specifications and limitations
we've also listed within this user guide, our pri-
mary advice is simply to pay attention to the limi-
tations indicated on the instrumentation, primar-
ily the airspeed indicator, the manifold pressure
gauge and the RPM gauge.

Have fun and keep the blue side up!

—— MLV
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Preflight Actions

1)  Adjust fuel quantities and weight as desired for flight
> Adjustments are made through the Flight Configuration Ul
a) When selecting the aircraft, press the “Customize” button
b) Next, press the “Weight, Balance & Fuel” button
c) Adjust as desired
» Tanks 1& 2 (the main tip tanks) are filled before aux tanks
> The usable C.G. range is from -1.5" (forward) to +2.8" (aft)

General Aviation

Twin Engine

Cessna

MilViz & ASDG
Aircraft/MilViz/Milviz Cessna 31

Weight, Balance, & Fuel Failures

2) Remove wheel chocks and covers
> This action can be done through a custom menu panel
> This panel is opened through the top Ul menu bar
> Choose “Plugins > MilViz T310R > Show/Hide Options”

Ground Equipment

Customize

WEIGHT, BALANCE, & FUEL

Show Units In

Center of Gravity
Payload Weight

Total Fuel Weight

Left Side Fuel Total

US Customary

Default

Ibs

EXH 'bs
EIT s

LVIZ ™ 7370R

MILITARY VISUALIZATIONS
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Before Starting Engines

1)  Set Parking Brake

> Hold the left mouse button, pull the lever out to set
2) Switch Fuel Selectors to Main Tanks

» Leftclick on the desired placard area to turn the selectors
3) Set Throttle, Propeller & Mixture levers

a) Set Mixture levers fully rich (forward)

b) Set Propeller levers fully forward

c) SetThrottle levers open approximately one inch

4)  Turn on Battery and Alternator Switches
> The lower switch panel is located directly below the yoke
> For easier access, the yoke may be hidden from view

» To hide the yoke, left click on the yoke shaft

—MILVIZ ==
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Before Starting Engines (continued)

5) Setlighting switches and dials as required
> Toggle switches ON/OFF with the left mouse button
> Rotate dials to adjust brightness with the mouse wheel
6) Set Altimeter to correct barometric pressure or elevation
» Use the adjustment knob at the bottom left of the altimeter
> Rotate the mouse wheel when over the adjustment knob
7) Open left and right Cowl Flaps

» Hold the left mouse button, pull or push control handles

—MILVIZ ==




Turbo 310R User Guide

Page 14

Starting Engines

(left engine is started first, then right engine)
1)  Turn on Magneto Switches
> Toggle switches ON with the left mouse button
2) StartEngine
a) Press Start button for desired engine
> Click the button using the left mouse button
b) Engage the Primer left or right, depending on engine
> Click and hold the primer switch and drag to left or right
3) Turn Auxiliary Fuel Pump switch to LOW
> Toggle switch to LOW with the left mouse button
4) Set Throttle lever to obtain 800 to 1000 RPM
(repeat steps 1through 4 for right engine)

—MILVIZ==
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Before Taxi

1)  Turn on Avionics Master Switch

> Toggle switch ON with the left mouse button
2) Turn on and set Avionics as desired
3) Release Parking Brake

> Brakes will release by pressing the toe brakes

> Brakes may also be released by using the control handle

You're cleared for takeoff, enjoy your flight!
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